1.10.1.4 WoT Tweaker Plus By Phantasm

  

1.10.1.4 WoT Tweaker Plus By Phantasm

– for the mod to work you will need to have Microsoft .NET Framework 4.5

19 thoughts on “1.10.1.4 WoT Tweaker Plus By Phantasm

  1. Easy to use, VERY usefull, dude, thats one of the best mods ive ever seen, i just would like to meet it earlier.

    1. Yep, a must use mod if you don’t want your eyes to suffer from all the crap on the screen. Plus the texture compression will allow wot to work even on integrated Intel graphics from 4-5 years ago…

  2. one must be quiet an idiot to download anything from russian sites….u get miners, trojans and a bundle of happy malware !!!

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.